$re = '/(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\u0020-\u002f\u003A-\u0040\u005B-\u0060\u007B-\u007E]).{8,}/mu';
$str = 'jhiuyJSY27
HU7987BVF6
HB5rrf67
GH5+m09b
jfi-09uyT
ok8^87VF
09POlo
09nbf4-DE
IGORMARIO
ndjh765b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);