import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\\u0020-\\u002f\\u003A-\\u0040\\u005B-\\u0060\\u007B-\\u007E]).{8,}";
final String string = "jhiuyJSY27\n"
+ "HU7987BVF6\n"
+ "HB5rrf67\n"
+ "GH5+m09b\n"
+ "jfi-09uyT\n"
+ "ok8^87VF\n"
+ "09POlo\n"
+ "09nbf4-DE\n"
+ "IGORMARIO\n"
+ "ndjh765b\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}