import Foundation
let pattern = #"(?:\G(?!^)(?(?=\d+(?:EXE_IN\.preparing|bbb\.xxx))(?<!\dccc\.xxx))|(?=(?:\d+(?:EXE_IN\.preparing|bbb\.xxx))+(?:\d+ccc\.xxx)+))(\d+)(EXE_IN\.preparing|bbb\.xxx|ccc\.xxx)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1EXE_IN.preparing2EXE_IN.preparing3EXE_IN.preparing4EXE_IN.preparing5EXE_IN.preparing6EXE_IN.preparing7bbb.xxx8ccc.xxx9ccc.xxx"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)