import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)(?(?=\\d+(?:EXE_IN\\.preparing|bbb\\.xxx))(?<!\\dccc\\.xxx))|(?=(?:\\d+(?:EXE_IN\\.preparing|bbb\\.xxx))+(?:\\d+ccc\\.xxx)+))(\\d+)(EXE_IN\\.preparing|bbb\\.xxx|ccc\\.xxx)";
final String string = "1EXE_IN.preparing2EXE_IN.preparing3EXE_IN.preparing4EXE_IN.preparing5EXE_IN.preparing6EXE_IN.preparing7bbb.xxx8ccc.xxx9ccc.xxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}