const regex = /(?:\G(?!^)(?(?=\d+(?:EXE_IN\.preparing|bbb\.xxx))(?<!\dccc\.xxx))|(?=(?:\d+(?:EXE_IN\.preparing|bbb\.xxx))+(?:\d+ccc\.xxx)+))(\d+)(EXE_IN\.preparing|bbb\.xxx|ccc\.xxx)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)(?(?=\\d+(?:EXE_IN\\.preparing|bbb\\.xxx))(?<!\\dccc\\.xxx))|(?=(?:\\d+(?:EXE_IN\\.preparing|bbb\\.xxx))+(?:\\d+ccc\\.xxx)+))(\\d+)(EXE_IN\\.preparing|bbb\\.xxx|ccc\\.xxx)', 'gm')
const str = `1EXE_IN.preparing2EXE_IN.preparing3EXE_IN.preparing4EXE_IN.preparing5EXE_IN.preparing6EXE_IN.preparing7bbb.xxx8ccc.xxx9ccc.xxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}