#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!^)(?(?=\d+(?:EXE_IN\.preparing|bbb\.xxx))(?<!\dccc\.xxx))|(?=(?:\d+(?:EXE_IN\.preparing|bbb\.xxx))+(?:\d+ccc\.xxx)+))(\d+)(EXE_IN\.preparing|bbb\.xxx|ccc\.xxx)"
Local $sString = "1EXE_IN.preparing2EXE_IN.preparing3EXE_IN.preparing4EXE_IN.preparing5EXE_IN.preparing6EXE_IN.preparing7bbb.xxx8ccc.xxx9ccc.xxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")