# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d\s(\d+\.\d+\s+)\s+(\d+\.\d+\.\d+)\s+(?P<XYZ>.*$)"
test_str = (" \n"
" Number of surface maxima: 7\n"
" # a.u. eV kcal/mol X/Y/Z coordinate(Angstrom)\n"
" 1 21.76342476 592.21290413656.766669 -6.892053 -0.425961 -0.514519\n"
" 2 21.95275305 597.36478913775.572064 -6.167357 1.713169 -0.882468")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.