use strict;
my $str = '
Number of surface maxima: 7
# a.u. eV kcal/mol X/Y/Z coordinate(Angstrom)
1 21.76342476 592.21290413656.766669 -6.892053 -0.425961 -0.514519
2 21.95275305 597.36478913775.572064 -6.167357 1.713169 -0.882468';
my $regex = qr/\d\s(\d+\.\d+\s+)\s+(\d+\.\d+\.\d+)\s+(?P<XYZ>.*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}