#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d\s(\d+\.\d+\s+)\s+(\d+\.\d+\.\d+)\s+(?P<XYZ>.*$)"
Local $sString = " " & @CRLF & _
" Number of surface maxima: 7" & @CRLF & _
" # a.u. eV kcal/mol X/Y/Z coordinate(Angstrom)" & @CRLF & _
" 1 21.76342476 592.21290413656.766669 -6.892053 -0.425961 -0.514519" & @CRLF & _
" 2 21.95275305 597.36478913775.572064 -6.167357 1.713169 -0.882468"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")