$re = '/\d\s(\d+\.\d+\s+)\s+(\d+\.\d+\.\d+)\s+(?P<XYZ>.*$)/m';
$str = '
Number of surface maxima: 7
# a.u. eV kcal/mol X/Y/Z coordinate(Angstrom)
1 21.76342476 592.21290413656.766669 -6.892053 -0.425961 -0.514519
2 21.95275305 597.36478913775.572064 -6.167357 1.713169 -0.882468';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);