use strict;
my $str = '12333-
1ee-
1333333-
121-121-1212
1444-444-4444
12-12-1122
sd-sd-ssss
121-212-22222
';
my $regex = qr/^[\d]{3}-[\d]{3}-[\d]{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}