const regex = /^[\d]{3}-[\d]{3}-[\d]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\d]{3}-[\\d]{3}-[\\d]{4}$', 'gm')
const str = `12333-
1ee-
1333333-
121-121-1212
1444-444-4444
12-12-1122
sd-sd-ssss
121-212-22222
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}