package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\d]{3}-[\d]{3}-[\d]{4}$`)
var str = `12333-
1ee-
1333333-
121-121-1212
1444-444-4444
12-12-1122
sd-sd-ssss
121-212-22222
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}