#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\d]{3}-[\d]{3}-[\d]{4}$"
Local $sString = "12333-" & @CRLF & _
"1ee-" & @CRLF & _
"1333333-" & @CRLF & _
"121-121-1212" & @CRLF & _
"1444-444-4444" & @CRLF & _
"12-12-1122" & @CRLF & _
"sd-sd-ssss" & @CRLF & _
"121-212-22222" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")