// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)KW[^a-zA-Z1-9]*([1-9]+\d*).*\d+\.\d+\.(\d+).*").unwrap();
let string = "KW-7%C2%AD_12.02.-16.02.2018.pdf
KW-8_12.02.-16.02.2018.pdf
KW-03_12.02.-16.2.2018.pdf
KW-43_12.2.-06.02.2018.pdf
KW-43_12.2.2017-06.02.2018.pdf
KW-43_12.2.2017-06.02.2018-extra.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}