# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"KW[^a-zA-Z1-9]*([1-9]+\d*).*\d+\.\d+\.(\d+).*"
test_str = ("KW-7%C2%AD_12.02.-16.02.2018.pdf\n"
"KW-8_12.02.-16.02.2018.pdf\n"
"KW-03_12.02.-16.2.2018.pdf\n"
"KW-43_12.2.-06.02.2018.pdf\n"
"KW-43_12.2.2017-06.02.2018.pdf\n"
"KW-43_12.2.2017-06.02.2018-extra.pdf")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.