package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)KW[^a-zA-Z1-9]*([1-9]+\d*).*\d+\.\d+\.(\d+).*`)
var str = `KW-7%C2%AD_12.02.-16.02.2018.pdf
KW-8_12.02.-16.02.2018.pdf
KW-03_12.02.-16.2.2018.pdf
KW-43_12.2.-06.02.2018.pdf
KW-43_12.2.2017-06.02.2018.pdf
KW-43_12.2.2017-06.02.2018-extra.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}