#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)KW[^a-zA-Z1-9]*([1-9]+\d*).*\d+\.\d+\.(\d+).*"
Local $sString = "KW-7%C2%AD_12.02.-16.02.2018.pdf" & @CRLF & _
"KW-8_12.02.-16.02.2018.pdf" & @CRLF & _
"KW-03_12.02.-16.2.2018.pdf" & @CRLF & _
"KW-43_12.2.-06.02.2018.pdf" & @CRLF & _
"KW-43_12.2.2017-06.02.2018.pdf" & @CRLF & _
"KW-43_12.2.2017-06.02.2018-extra.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")