re = /\.jpg|jpeg/m
str = 'ar.txt
s.zip
ddr
eff.jpg
karo.gif
spb.pdf
lego.jpeg
some.jpg
erro.exe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end