$re = '/\.jpg|jpeg/m';
$str = 'ar.txt
s.zip
ddr
eff.jpg
karo.gif
spb.pdf
lego.jpeg
some.jpg
erro.exe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);