#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.jpg|jpeg"
Local $sString = "ar.txt" & @CRLF & _
"s.zip" & @CRLF & _
"ddr" & @CRLF & _
"eff.jpg" & @CRLF & _
"karo.gif" & @CRLF & _
"spb.pdf" & @CRLF & _
"lego.jpeg" & @CRLF & _
"some.jpg" & @CRLF & _
"erro.exe" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")