package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.jpg|jpeg`)
var str = `ar.txt
s.zip
ddr
eff.jpg
karo.gif
spb.pdf
lego.jpeg
some.jpg
erro.exe
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}