$re = '/^(-?(\d*\.)?\d+)((px)|(em)|(%)|(ex)|(ch)|(rem)|(vw)|(vh)|(vmin)|(vmax)|(cm)|(mm)|(in)|(pt)|(pc))$/mi';
$str = '23px
3.32423423cm
.87687533mm
34223423em
23423423%
234ex
67ch
4535rem
1vw
435345vh
3.456456vmin
23424234.23423423px
0.3vmax
1pt
435345pc
3.456456in
-23px
-3.32423423cm
-.87687533mm
-34223423em
-23423423%
-234ex
-67ch
-4535rem
-1vw
-435345vh
-3.456456vmin
-23424234.23423423px
-0.3vmax
-1pt
-435345pc
-3.456456in
-1vw
-3.456456vmin';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);