using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?(\d*\.)?\d+)((px)|(em)|(%)|(ex)|(ch)|(rem)|(vw)|(vh)|(vmin)|(vmax)|(cm)|(mm)|(in)|(pt)|(pc))$";
string input = @"23px
3.32423423cm
.87687533mm
34223423em
23423423%
234ex
67ch
4535rem
1vw
435345vh
3.456456vmin
23424234.23423423px
0.3vmax
1pt
435345pc
3.456456in
-23px
-3.32423423cm
-.87687533mm
-34223423em
-23423423%
-234ex
-67ch
-4535rem
-1vw
-435345vh
-3.456456vmin
-23424234.23423423px
-0.3vmax
-1pt
-435345pc
-3.456456in
-1vw
-3.456456vmin";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}