#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(-?(\d*\.)?\d+)((px)|(em)|(%)|(ex)|(ch)|(rem)|(vw)|(vh)|(vmin)|(vmax)|(cm)|(mm)|(in)|(pt)|(pc))$"
Local $sString = "23px" & @CRLF & _
"3.32423423cm" & @CRLF & _
".87687533mm" & @CRLF & _
"34223423em" & @CRLF & _
"23423423%" & @CRLF & _
"234ex" & @CRLF & _
"67ch" & @CRLF & _
"4535rem" & @CRLF & _
"1vw" & @CRLF & _
"435345vh" & @CRLF & _
"3.456456vmin" & @CRLF & _
"23424234.23423423px" & @CRLF & _
"0.3vmax" & @CRLF & _
"1pt" & @CRLF & _
"435345pc" & @CRLF & _
"3.456456in" & @CRLF & _
"" & @CRLF & _
"-23px" & @CRLF & _
"-3.32423423cm" & @CRLF & _
"-.87687533mm" & @CRLF & _
"-34223423em" & @CRLF & _
"-23423423%" & @CRLF & _
"-234ex" & @CRLF & _
"-67ch" & @CRLF & _
"-4535rem" & @CRLF & _
"-1vw" & @CRLF & _
"-435345vh" & @CRLF & _
"-3.456456vmin" & @CRLF & _
"-23424234.23423423px" & @CRLF & _
"-0.3vmax" & @CRLF & _
"-1pt" & @CRLF & _
"-435345pc" & @CRLF & _
"-3.456456in" & @CRLF & _
"-1vw" & @CRLF & _
"-3.456456vmin"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")