const regex = /^(-?(\d*\.)?\d+)((px)|(em)|(%)|(ex)|(ch)|(rem)|(vw)|(vh)|(vmin)|(vmax)|(cm)|(mm)|(in)|(pt)|(pc))$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?(\\d*\\.)?\\d+)((px)|(em)|(%)|(ex)|(ch)|(rem)|(vw)|(vh)|(vmin)|(vmax)|(cm)|(mm)|(in)|(pt)|(pc))$', 'gmi')
const str = `23px
3.32423423cm
.87687533mm
34223423em
23423423%
234ex
67ch
4535rem
1vw
435345vh
3.456456vmin
23424234.23423423px
0.3vmax
1pt
435345pc
3.456456in
-23px
-3.32423423cm
-.87687533mm
-34223423em
-23423423%
-234ex
-67ch
-4535rem
-1vw
-435345vh
-3.456456vmin
-23424234.23423423px
-0.3vmax
-1pt
-435345pc
-3.456456in
-1vw
-3.456456vmin`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}