$re = '/\ /m';
$str = 'cat and dog.mp3
rihana and shakira.mp3
me and ma.mp3';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;