const regex = /\ /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\ ', 'gm')
const str = `cat and dog.mp3
rihana and shakira.mp3
me and ma.mp3`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);