use strict;
my $str = 'cat and dog.mp3
rihana and shakira.mp3
me and ma.mp3';
my $regex = qr/\ /mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";