package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\ `)
var str = `cat and dog.mp3
rihana and shakira.mp3
me and ma.mp3`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}