// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)(-)(.*)(-)(.*)").unwrap();
let string = "2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-11-11
2015-12-11
2015-12-11
";
let substitution = "\\1\\2\\5\\4\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}