use strict;
my $str = '2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-11-11
2015-12-11
2015-12-11
';
my $regex = qr/(.*)(-)(.*)(-)(.*)/mp;
my $subst = '\\1\\2\\5\\4\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";