$re = '/(.*)(-)(.*)(-)(.*)/m';
$str = '2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-09-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-10-11
2015-11-11
2015-12-11
2015-12-11
';
$subst = "\1\2\5\4\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;