# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(-)(.*)(-)(.*)"
test_str = ("2015-09-11\n"
"2015-09-11\n"
"2015-09-11\n"
"2015-09-11\n"
"2015-09-11\n"
"2015-09-11\n"
"2015-09-11\n"
"2015-10-11\n"
"2015-10-11\n"
"2015-10-11\n"
"2015-10-11\n"
"2015-10-11\n"
"2015-10-11\n"
"2015-11-11\n"
"2015-12-11\n"
"2015-12-11\n")
subst = "\\1\\2\\5\\4\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.