# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(0*10*)((11)*|0*)((0*10*10*)*|111)0*"
test_str = ("01\n"
"01\n"
"001\n"
"00000100000011\n"
"1000\n"
"111\n"
"0001110110000\n"
"0010010001\n"
"0000000100000000\n"
"000000011111110000000\n"
"000000000100000000\n"
"0000000111\n"
"0\n"
"00\n"
"0010010011111111100\n"
"01110000\n"
"000001110000\n"
"01110111000111\n"
"011101010101\n"
"0111010101011111")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.