use strict;
my $str = '01
01
001
00000100000011
1000
111
0001110110000
0010010001
0000000100000000
000000011111110000000
000000000100000000
0000000111
0
00
0010010011111111100
01110000
000001110000
01110111000111
011101010101
0111010101011111';
my $regex = qr/(0*10*)((11)*|0*)((0*10*10*)*|111)0*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}