import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0*10*)((11)*|0*)((0*10*10*)*|111)0*";
final String string = "01\n"
+ "01\n"
+ "001\n"
+ "00000100000011\n"
+ "1000\n"
+ "111\n"
+ "0001110110000\n"
+ "0010010001\n"
+ "0000000100000000\n"
+ "000000011111110000000\n"
+ "000000000100000000\n"
+ "0000000111\n"
+ "0\n"
+ "00\n"
+ "0010010011111111100\n"
+ "01110000\n"
+ "000001110000\n"
+ "01110111000111\n"
+ "011101010101\n"
+ "0111010101011111";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}