#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(0*10*)((11)*|0*)((0*10*10*)*|111)0*"
Local $sString = "01" & @CRLF & _
"01" & @CRLF & _
"001" & @CRLF & _
"00000100000011" & @CRLF & _
"1000" & @CRLF & _
"111" & @CRLF & _
"0001110110000" & @CRLF & _
"0010010001" & @CRLF & _
"0000000100000000" & @CRLF & _
"000000011111110000000" & @CRLF & _
"000000000100000000" & @CRLF & _
"0000000111" & @CRLF & _
"0" & @CRLF & _
"00" & @CRLF & _
"0010010011111111100" & @CRLF & _
"01110000" & @CRLF & _
"000001110000" & @CRLF & _
"01110111000111" & @CRLF & _
"011101010101" & @CRLF & _
"0111010101011111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")