import Foundation
let pattern = #"([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}),{1,100}|([0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}),{1,100}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"10-10-02-03-16-01,10-10-02-03-16-02,10-10-02-03-16-03,10-10-02-03-16-04,10-10-02-03-16-05,10-10-02-03-16-06,10-10-02-03-16-07,10-10-02-03-16-08,10-10-02-03-16-09,10-10-02-03-16-10,"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)