#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}),{1,100}|([0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}),{1,100}"
Local $sString = "10-10-02-03-16-01,10-10-02-03-16-02,10-10-02-03-16-03,10-10-02-03-16-04,10-10-02-03-16-05,10-10-02-03-16-06,10-10-02-03-16-07,10-10-02-03-16-08,10-10-02-03-16-09,10-10-02-03-16-10,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")