using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}),{1,100}|([0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}),{1,100}";
string input = @"10-10-02-03-16-01,10-10-02-03-16-02,10-10-02-03-16-03,10-10-02-03-16-04,10-10-02-03-16-05,10-10-02-03-16-06,10-10-02-03-16-07,10-10-02-03-16-08,10-10-02-03-16-09,10-10-02-03-16-10,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}