const regex = /([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}),{1,100}|([0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}\\.[0-9a-fA-F]{4}),{1,100}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}),{1,100}|([0-9a-fA-F]{4}\\\\.[0-9a-fA-F]{4}\\\\.[0-9a-fA-F]{4}),{1,100}', 'gm')
const str = `10-10-02-03-16-01,10-10-02-03-16-02,10-10-02-03-16-03,10-10-02-03-16-04,10-10-02-03-16-05,10-10-02-03-16-06,10-10-02-03-16-07,10-10-02-03-16-08,10-10-02-03-16-09,10-10-02-03-16-10,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}