use strict;
my $str = '# Genuine values
63638-1
8867-4
55231-5
26464-8
22577-1
# Checking edge cases
12-1
123-1
12345678-9
123456789-9
12345678
12345678-
12345678--
12345678-A
12345678-?
12345678-12
# Adding letters to the main code
LL2435-7
LL358-3
';
my $regex = qr/^[a-zA-Z0-9]{3,8}-\d{1}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}