using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9]{3,8}-\d{1}$";
string input = @"# Genuine values
63638-1
8867-4
55231-5
26464-8
22577-1
# Checking edge cases
12-1
123-1
12345678-9
123456789-9
12345678
12345678-
12345678--
12345678-A
12345678-?
12345678-12
# Adding letters to the main code
LL2435-7
LL358-3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}