import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9]{3,8}-\\d{1}$";
final String string = "# Genuine values\n"
+ "63638-1\n"
+ "8867-4\n"
+ "55231-5\n"
+ "26464-8\n"
+ "22577-1\n"
+ "# Checking edge cases\n"
+ "12-1\n"
+ "123-1\n"
+ "12345678-9\n"
+ "123456789-9\n"
+ "12345678\n"
+ "12345678-\n"
+ "12345678--\n"
+ "12345678-A\n"
+ "12345678-?\n"
+ "12345678-12\n"
+ "# Adding letters to the main code\n"
+ "LL2435-7\n"
+ "LL358-3\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}