package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]{3,8}-\d{1}$`)
var str = `# Genuine values
63638-1
8867-4
55231-5
26464-8
22577-1
# Checking edge cases
12-1
123-1
12345678-9
123456789-9
12345678
12345678-
12345678--
12345678-A
12345678-?
12345678-12
# Adding letters to the main code
LL2435-7
LL358-3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}