# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a([^>]*)>)(<img([^>]*)>)"
test_str = "<a href=\"http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229.png\"><img class=\"aligncenter wp-image-4054\" src=\"http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229-563x1000.png\" alt=\"\" width=\"339\" height=\"602\" /></a>"
subst = "<div>\\1 \\3</div>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.