using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a([^>]*)>)(<img([^>]*)>)";
string substitution = @"<div>\1 \3</div>";
string input = @"<a href=""http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229.png""><img class=""aligncenter wp-image-4054"" src=""http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229-563x1000.png"" alt="" width=""339"" height=""602"" /></a>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}