$re = '/(<a([^>]*)>)(<img([^>]*)>)/i';
$str = '<a href="http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229.png"><img class="aligncenter wp-image-4054" src="http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229-563x1000.png" alt="" width="339" height="602" /></a>';
$subst = "<div>\1 \3</div>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;