const regex = /(<a([^>]*)>)(<img([^>]*)>)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a([^>]*)>)(<img([^>]*)>)', 'i')
const str = `<a href="http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229.png"><img class="aligncenter wp-image-4054" src="http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229-563x1000.png" alt="" width="339" height="602" /></a>`;
const subst = `<div>\1 \3</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);